Discussion:
nixos-unstable-small channel is not updating anymore
(too old to reply)
Vladimír Čunát
2017-06-26 14:37:52 UTC
Permalink
Hi.
That channel hasn't updated for over a week now and it's unclear why, as
all the jobs succeeded on most evaluations during the past week.

--Vladimir
Graham Christensen
2017-06-26 15:06:02 UTC
Permalink
Post by Vladimír Čunát
Hi.
That channel hasn't updated for over a week now and it's unclear why, as
all the jobs succeeded on most evaluations during the past week.
--Vladimir
Interesting, according to
https://channels.nix.gsc.io/nixos-unstable-small/history and
https://channels.nix.gsc.io/graph.html it has been updating quite
regularly.

I'm monitoring the github repository at
https://github.com/nixos/nixpkgs-channels/tree/nixos-unstable-small
which has been updating.

I wonder why nixos.org/channels hasn't been keeping up?

Graham
Eelco Dolstra
2017-06-26 17:22:49 UTC
Permalink
Hi,
Post by Vladimír Čunát
That channel hasn't updated for over a week now and it's unclear why, as
all the jobs succeeded on most evaluations during the past week.
Jun 26 17:12:09 webserver update-nixos-unstable-small-start[13607]: 34 top-level paths, 619 paths in closure
Jun 26 17:12:49 webserver update-nixos-unstable-small-start[13607]: error: in package ‘libsForQt5.qtinstaller’: this derivation has bad ‘meta.outputsToInstall’
Jun 26 17:12:49 webserver update-nixos-unstable-small-start[13607]: Died at /nix/store/r23zn67lg3b55pw990smqsh51g19rax0-nixos-channel-scripts/bin/.mirror-nixos-branch-wrapped line 157.
--
Eelco Dolstra | LogicBlox, Inc. | http://nixos.org/~eelco/
Vladimír Čunát
2017-06-26 17:53:01 UTC
Permalink
Post by Vladimír Čunát
error: in package ‘libsForQt5.qtinstaller’: this derivation has bad
‘meta.outputsToInstall’
Right, this particular error is fixed by ce8178ed931a. Is it possible
to make such errors visible somewhere, e.g. on Hydra?

--Vladimir
Daniel Peebles
2017-06-26 17:57:59 UTC
Permalink
This sort of thing seems like it could also be caught by this feature I
added a few weeks ago: https://github.com/NixOS/nixpkgs/pull/25304

It started off disabled by default, then I tried enabling it by default,
and then disabled it by default again. It checks meta fields against a
schema and fails builds if they fail. We could enable it by default again?
Post by Vladimír Čunát
error: in package ‘libsForQt5.qtinstaller’: this derivation has bad
‘meta.outputsToInstall’
Right, this particular error is fixed by ce8178ed931a. Is it possible
to make such errors visible somewhere, e.g. on Hydra?
--Vladimir
_______________________________________________
nix-dev mailing list
https://mailman.science.uu.nl/mailman/listinfo/nix-dev
Loading...